[Mesa-users] Trying to get mesa version 13311

Warrick Ball W.H.Ball at bham.ac.uk
Tue Oct 4 09:40:03 UTC 2022

Hi Lexie,

I think r13311 was back when the file that stores the version number (`$MESA_DIR/data/version_number`) wasn't updated automatically, and not consistently outside of releases.  From the SVN log, it looks like the file wasn't updated between r13308 and r13317.  So you almost certainly do have r13311 when you check it out of the old SVN repo, it's just that the data file wasn't updated.

If you type `svn info` wherever you checked out MESA, you should see some information that includes a line like

     $ svn info
     Revision: 13311

You can do `svn info data/version_number` too, which should show that the file was last updated in r13308.



Warrick Ball
Postdoc, School of Physics and Astronomy
University of Birmingham, Edgbaston, Birmingham B15 2TT
W.H.Ball at bham.ac.uk
+44 (0)121 414 4552

On Tue, 4 Oct 2022, mesa-users at lists.mesastar.org wrote:

> Hello mesa users,
> I'm trying to reproduce the plots from a "The impact of stellar rotation on the black hole mass-gap from pair-instability supernovae" using the template test suite
> here: https://zenodo.org/record/3940340#.YzuGY9LMJcd. I've followed the instructions here:https://zenodo.org/record/4745225#.YzuGydLMJce to get the correct version of mesa for the template, 13311.
> I used the command "svn co -r 13311 file:////home/adholtha/lus_scratch/mesa/ ./mesa-r13311/" to check out version 13311, but when I run mesa it says the version number is 13308. I also tried checking out
> version 13314 to see what would happen and it also runs as 13308.
> Is there some other command I should be using? 
> Thank you,
> Lexie Holthaus

More information about the Mesa-users mailing list