[Mesa-users] compiling errors

AbdelBassit Senhadji sen-abd at hotmail.fr
Wed May 18 16:04:39 UTC 2022

Hi Warrick,

I was using the same version of MESA (R15140). The problem was in the  'star/other/other_*.f90` routines. I did some changes and now it is compiling perfectly. Thanks for the help.

But now this is what I am getting when I run the code:

I have not changed anything else in the inlists or src files.

What do you think about this error? I never had that before.


TIME: 11:58:48
 version_number 15140
 read inlist_wd_builder
 read inlist_model

 The terminal output contains the following information

      'step' is the number of steps since the start of the run,
      'lg_dt' is log10 timestep in years,
      'age_yr' is the simulated years since the start run,
      'lg_Tcntr' is log10 center temperature (K),
      'lg_Dcntr' is log10 center density (g/cm^3),
      'lg_Tmax' is log10 max temperature (K),
      'Teff' is the surface temperature (K),
      'lg_R' is log10 surface radius (Rsun),
      'lg_L' is log10 surface luminosity (Lsun),
      'lg_LH' is log10 total PP and CNO hydrogen burning power (Lsun),
      'lg_L3a' is log10 total triple-alpha helium burning power (Lsun),
      'lg_gsurf' is log10 surface gravity,
      'lg_LNuc' is log10 nuclear power (Lsun),
      'lg_LNeu' is log10 total neutrino power (Lsun),
      'lg_Lphoto' is log10 total photodisintegration (Lsun),
      'Mass' is the total stellar baryonic mass (Msun),
      'lg_Mdot' is log10 magnitude of rate of change of mass (Msun/year),
      'lg_Dsurf' is log10 surface density (g/cm^3),
      'H_env' is the amount of mass where H is the most abundant iso,
      'He_core' is the largest mass where He is most abundant iso.
      'C_core' is the largest mass where C is most abundant iso.
      'H_cntr' is the center H1 mass fraction,
      'He_cntr' is the center He4 mass fraction,
      'C_cntr' is the center C12 mass fraction,
      'N_cntr' is the center N14 mass fraction,
      'O_cntr' is the center O16 mass fraction,
      'Ne_cntr' is the center Ne20 mass fraction,
      'gam_cntr' is the center plasma interaction parameter,
      'eta_cntr' is the center electron degeneracy parameter,
      'zones' is the number of zones in the current model,
      'iters' is the number of solver iterations for the current step,
      'retry' is the number of step retries required during the run,
      'dt_limit' is an indication of what limited the timestep.

 All this and more are saved in the LOGS directory during the run.
 create initial model

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  0x7fc2b5e1a51f in ???
#1  0x0 in ???
./rn: line 6:  9120 Segmentation fault      (core dumped) ./star
DATE: 2022-05-18
TIME: 11:58:50

De : Warrick Ball <W.H.Ball at bham.ac.uk>
Envoyé : 18 mai 2022 08:35
À : AbdelBassit Senhadji <sen-abd at hotmail.fr>
Cc : mesa-users at lists.mesastar.org <mesa-users at lists.mesastar.org>
Objet : Re: [Mesa-users] compiling errors

Hi Abdel,

What version of MESA are you using, and does it correspond to the version associated with Schwab (2021)?

My guess is that the interface for the `other_mlt` hook has changed since the code in the Zenodo entry was written.

If you want the extra code to work with the MESA release you're using, check that the hooks use the interfaces defined in the `star/other/other_*.f90` routines.



Warrick Ball
Postdoc, School of Physics and Astronomy
University of Birmingham, Edgbaston, Birmingham B15 2TT
W.H.Ball at bham.ac.uk
+44 (0)121 414 4552

On Tue, 17 May 2022, mesa-users at lists.mesastar.org wrote:

> Good afternoon,
> I have downloaded a zip file to build a massive WD from https://nam12.safelinks.protection.outlook.com/?url=https%3A%2F%2Fzenodo.org%2Frecord%2F5047378%23.YoQYAHXMJ-0&data=05%7C01%7C%7Ca987ab7bb9ba48271e8e08da38caecc2%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637884741473393923%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=1kmFfq1HIAQLR7Lzp3jZsSzYEBu9FFlj%2BQtVUKTKErw%3D&reserved=0
> Cooling Models for the Most Massive White Dwarfs | Zenodo
> Input and output files associated with Schwab (2021). See README in zipfile. Version 2 is after peer review and first proofs, reflecting some changes in the plots due to revisions in the quoted properties of
> ZTF J190132.9+145808.7. (The MESA models remain unchanged from version 1.)
> zenodo.org
> I've tried to compile and checked the necessary flags, but still having the errors below. Not only that, but I was not able to solve the problem, any advice?
> Thanks in advance for your help!
> Abdel
> (base) abdel at pop-os:~/PHD/NOVAE/wd_builder_models$ ./clean (base) abdel at pop-os:~/PHD/NOVAE/wd_builder_models$ ./mk
> gfortran -Wno-uninitialized -fno-range-check -fmax-errors=7  -fprotect-parens -fno-sign-zero -fbacktrace -ggdb -finit-real=snan -fopenmp -fbounds-check -Wuninitialized -Warray-bounds -ggdb -ffree-form
> -ffree-line-length-none -x f95-cpp-input -I/home/abdel/mesa-r15140/include -I../src -c ../src/run_star_extras.f90
> wd_builder.inc:257:37:
> Error: Symbol 'num_kap_fracs' at (1) has no IMPLICIT type; did you mean 'kap_fracs'?
> ../src/run_star_extras.f90:597:57:
>   597 |             mixing_type, mlt_basics, mlt_partials1, ierr)
>       |                                                         1
> Error: Type mismatch in argument 'dt' at (1); passed LOGICAL(4) to REAL(8)
> ../src/run_star_extras.f90:243:25:
>   243 |          s% other_mlt => my_other_mlt
>       |                         1
> Error: Interface mismatch in procedure pointer assignment at (1): Type mismatch in argument 'dt' (REAL(8)/LOGICAL(4))
> wd_builder.inc:685:52:
> Error: Type mismatch in argument 'dt' at (1); passed LOGICAL(4) to REAL(8)
> wd_builder.inc:331:17:
> Error: Rank mismatch in argument 'z' at (1) (scalar and rank-1)
> wd_builder.inc:350:70:
> Error: Type mismatch in argument 'zbar' at (1); passed INTEGER(4) to REAL(8)
> wd_builder.inc:447:82:
> Error: Type mismatch in argument 'zbar' at (1); passed INTEGER(4) to REAL(8)
> compilation terminated due to -fmax-errors=7.
> make: *** [/home/abdel/mesa-r15140/star/work_standard_makefile:39: run_star_extras.o] Error 1
> (base) abdel at pop-os:~/PHD/NOVAE/wd_builder_models$
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20220518/8629a3c4/attachment.htm>

More information about the Mesa-users mailing list