[Mesa-users] Trouble updating to r21.12.1

Trevor Dorn-Wallenstein trevorzaylen at gmail.com
Thu Jan 13 21:39:31 UTC 2022

Hi all,

I'm trying to update MESA from r12778 to r21.12.1. I've downloaded and
installed the most recent MESA SDK (mesasdk-x86_64-macos-21.11.1) onto my
machine (2019 Macbook pro running macOS Catalina 10.15.7 with an Intel
core). The installation fails on the star package, and I get the error

dyld: Library not loaded: /opt/X11/lib/libX11.6.dylib
  Referenced from: /Applications/mesasdk/lib/libpgplot.dylib
  Reason: Incompatible library version: libpgplot.dylib requires version
11.0.0 or later, but libX11.6.dylib provides version 10.0.0
./ck: line 14: 66725 Abort trap: 6           ./star > log


TEST FAILED -- compare test_output to tmp.txt

./build_and_test FAILED

I've attached the build log to this email as well. I've tried a few
different things (cleaning and attempting to install again, uninstalling
then reinstalling the Xcode command line tools and then the SDK), but I
keep getting the same error.

Has anyone run into this before, or know of a way to fix it?


Trevor Dorn-Wallenstein
Postdoctoral Scholar
University of Washington Astronomy Department
Pronouns: he/him
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20220113/83ad457a/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: build.log
Type: application/octet-stream
Size: 40325 bytes
Desc: not available
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20220113/83ad457a/attachment.obj>

More information about the Mesa-users mailing list