[Mesa-users] Installing old MESA version on new Mac OS with M1

Falk Herwig fherwig at uvic.ca
Tue Dec 13 06:11:23 UTC 2022

Hi Fabian,

I confirm that none of the available NuDocker images can build version 12778. However, I have created pushed a new image with version number 20.031 and updated the documentation. This NuDocker image will run 12778 and is available in the usual way via Docker Hub.

More generally I should say that the intention was never that the existing set of NuDocker images can run all MESA versions, but the hope was that providing the templated Dockerfile would allow users to build additional images as needed.

I also looked a bit into the Apple silicon issue, again see NuDocker repo README.md: https://github.com/NuGrid/NuDocker#apple-silicon-m1m2

The short of it is that Apple silicon can run the NuDocker images, but it is very slow. However, on Intel Apple’s it is really fast.

Best, Falk

Dr Falk Herwig, Professor
Dept of Physics & Astronomy
University of Victoria

Email: fherwig at uvic.ca
Tel: +1 (250) 721-7743
Twitter: @fherwig

On Dec 11, 2022, at 11:42 AM, Fabian Schneider <fabian.schneider at uni-heidelberg.de<mailto:fabian.schneider at uni-heidelberg.de>> wrote:

Dear all,

We are running a Mesa lab alongside a stellar astrophysics lecture using the rather old 12778 version. Some students with macOS Monterey (Version 12.4 and the new M1 chip) were running into problems with installing the MESA SDK from September 10 2021 recommended for compiling older MESA versions. They are, however, able to install the latest SDK and MESA version. Usually, the MESA SDK installer simply exits with an error message that the installation did not succeed (we used the native installer and their bash is also set to use native). We also tried using the latest SDK and a MESA patch circulated on this mailinglist to compile MESA 12778 with the latest compiler collection but without success.

I am myself not a Mac user and have little to no experience with Macs. I was wondering whether someone else encountered the same issue and might have a solution at hand - I hope I did not miss an old mail thread on this. The students also tried NuDocker, apparently without success.

Any hints are much appreciated!

Best wishes,

mesa-users at lists.mesastar.org<mailto:mesa-users at lists.mesastar.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20221213/c63a2a71/attachment.htm>

More information about the Mesa-users mailing list