[Mesa-users] Installing old MESA version on new Mac OS with M1

Fabian Schneider fabian.schneider at uni-heidelberg.de
Sun Dec 11 19:42:58 UTC 2022

Dear all,

We are running a Mesa lab alongside a stellar astrophysics lecture using 
the rather old 12778 version. Some students with macOS Monterey (Version 
12.4 and the new M1 chip) were running into problems with installing the 
MESA SDK from September 10 2021 recommended for compiling older MESA 
versions. They are, however, able to install the latest SDK and MESA 
version. Usually, the MESA SDK installer simply exits with an error 
message that the installation did not succeed (we used the native 
installer and their bash is also set to use native). We also tried using 
the latest SDK and a MESA patch circulated on this mailinglist to 
compile MESA 12778 with the latest compiler collection but without success.

I am myself not a Mac user and have little to no experience with Macs. I 
was wondering whether someone else encountered the same issue and might 
have a solution at hand - I hope I did not miss an old mail thread on 
this. The students also tried NuDocker, apparently without success.

Any hints are much appreciated!

Best wishes,

More information about the Mesa-users mailing list