[Mesa-users] error installing mesa-r10398

Danny Sun dannysun at princeton.edu
Sat Dec 3 20:11:10 UTC 2022

Hi all,

I am trying to install mesa-r10398 on my laptop, but get the following
error when it builds the const package. The error

gfortran -Wno-uninitialized -fno-range-check
-fmax-errors=12  -fprotect-parens -fno-sign-zero -fbacktrace -ggdb
-finit-real=snan -fopenmp -I../../make -I../../public -I../../../include
-fbounds-check -Wuninitialized -Warray-bounds  -c -ffixed-form
-ffixed-line-length-132 -x f77-cpp-input ../src/test_const.f

gfortran -fopenmp -o ../tester test_const.o -L../../make -lconst

ld: library not found for -lSystem

collect2: error: ld returned 1 exit status

make: *** [tester] Error 1




./build_and_test FAILED

I am using macOS 12.6 (Monterey),

MESA version: mesa-r10398

SDK: mesasdk-x86_64-osx-10.14-20181104 (I also tried

gfortran -v: gcc version 7.2.0 (GCC)

echo $MESA_DIR: /Users/dsun/Desktop/mesa-r10398/

echo $MESASDK_ROOT: /Applications/mesasdk

The error "library not found for -lSystem" is apparently fixed
in mesasdk-x86_64-macos-20.9.1 in response to Xcode 12, but in order to
install the earlier version of MESA I believe I also need the corresponding

I also have installed all the command line tools using "xcode-select
-install" and tried "open
but get that the file does not exist.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20221203/77510901/attachment.htm>

More information about the Mesa-users mailing list