[Mesa-users] Error in reading net for create_merger_model

Mathieu Renzo mrenzo at flatironinstitute.org
Tue Aug 23 17:13:28 UTC 2022


Hi Nicholas,

another point of reference that may be useful is 
https://bitbucket.org/mrenzo/mesa_merger/src/master/, which I think was 
the basis for the lab linked by Rob below. This is for an older MESA 
version (15140), and is the code associated to this paper 
<https://ui.adsabs.harvard.edu/abs/2020ApJ...904L..13R/abstract>.  I 
know other users have managed to adapt this setup to their needs too, so 
maybe it can offer you some insight.

In my experience, to make up post-merger structures it is best to work 
with small nuclear networks (e.g., basic), which should be fine since 
nuclear physics usually has a timescale longer than the dynamical phase 
of the merger anyways. Only once you have a settled post-merger 
structure, you then can change the nuclear network to something bigger 
(either on the fly from your run_star_extras.f90 or stopping, saving a 
model and reloading it). Whether this is acceptable or not for your 
science case is up to you.

Mathieu

On 8/23/22 07:29, Rob Farmer via Mesa-users wrote:
> Hi,
>
> I don't have a fix for MESA but there was a similar process in 
> https://billwolf.space/projects/massive_binaries_2021/ which ships a 
> python file to do the merger so that may work better.
>
> Rob
>
> On Tue, 23 Aug 2022 at 00:56, Nicholas Rui via Mesa-users 
> <mesa-users at lists.mesastar.org> wrote:
>
>     Hi,
>
>     I'm currently trying to use the experimental create_merger_model
>     routine in the most recent version, r22.05.1 (inlist and model
>     files attached). The models and run use the pp_and_cno_extras.net
>     <http://pp_and_cno_extras.net> network. However, the run appears
>     to terminate with the error attached at the bottom of this email.
>
>     I have tried to replace the model files with other model files
>     using basic.net <http://basic.net> which I know have worked in
>     r12778, but it throws an identical error except referencing
>     basic.net <http://basic.net> (even when the inlist still specifies
>     pp_and_cno_extras.net <http://pp_and_cno_extras.net> - indicating
>     that the problem is in reading the model files rather than the net
>     directly specified in inlist_project).
>
>     I recognize that this option is somewhat experimental (and may not
>     have been touched/tested for several updates), but I'm holding out
>     hope that there's a simple thing that I'm overlooking re: reading
>     in these models.
>
>     Thanks in advance;
>     Nicholas Rui
>
>      All this and more are saved in the LOGS directory during the run.
>     add_reaction_for_handle failed in reaclib_parse_handle
>      invalid rate file
>      read_rates_from_files for num=           1
>      set_net failed in net_tables
>      do_read_saved_model failed in set_net for net_name =
>     pp_and_cno_extras.net <http://pp_and_cno_extras.net>
>      load failed in do_read_saved_model
>      star_read_model ierr          -1
>      create_merger_model ierr          -1
>      do_load1_star ierr          -1
>      do_before_evolve_loop ierr          -1
>      do_before_evolve_loop ierr          -1
>     DATE: 2022-08-22
>     TIME: 15:31:55
>     _______________________________________________
>     mesa-users at lists.mesastar.org
>     https://lists.mesastar.org/mailman/listinfo/mesa-users
>
>
> _______________________________________________
> mesa-users at lists.mesastar.org
> https://lists.mesastar.org/mailman/listinfo/mesa-users
>

-- 
Mathieu Renzo <https://users.flatironinstitute.org/~mrenzo/>
Flatiron Research Fellow
Center for Computational Astrophysics
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20220823/4eed2646/attachment.htm>


More information about the Mesa-users mailing list