[Mesa-users] macOS: SDK and libraries from r11701

Francis Timmes fxt44 at mac.com
Wed Nov 17 22:09:49 UTC 2021

hi alejandro,

my preferred solution for running older versions of mesa is nudocker:


runs in such an ubuntu-based docker container is a touch slower 
than running natively, but its invaluable for running older versions 
without the pain points that you describe.


> On Nov 17, 2021, at 3:06 AM, Alejandro Vigna Gomez via Mesa-users <mesa-users at lists.mesastar.org> wrote:
> Hi all,
> I’ve been trying to re-run some models from Du Buisson et al. 2020 [1,2] in my mac*. These models were done on MESA r11701. I downloaded that version and its SDK (both of them, actually), set the environmental variables and activated them. I failed compiling as the libz libraries (-lz) were not found. This is not an issue in the SDK from r12115. However, using that SDK leads to some segmentation faults (fairly, I guess). I tried reinstalling xcode, and redoing the whole drill, leading to the same fate.
> I know those old SDKs are no longer maintained, but was wondering if anyone has dealt with something similar (and successfully solved it) or knows how to circumvent the compiler and manually set location of the libz libraries? I tried the latter, but failed (I am not an expert in compilers nor in MESA SDKs). Comments appreciated. Cheers,
> Alejandro
> [1] https://ui.adsabs.harvard.edu/abs/2020MNRAS.499.5941D/abstract
> [2] https://zenodo.org/record/3667546
> * macOS 2019, with Intel processor, recently updated to v12 (Monterey), but what I describe happened identically before the update.
> ___________________________________
> Dr. Alejandro Vigna-Gomez
> www.alejandrovignagomez.com
> DARK Fellow
> Universitetsparken 5
> 2200 København N
> _______________________________________________
> mesa-users at lists.mesastar.org
> https://lists.mesastar.org/mailman/listinfo/mesa-users

More information about the Mesa-users mailing list