[Mesa-users] relaxing entropy

Akaash Conhye ac01283 at surrey.ac.uk
Wed Sep 16 07:36:54 EDT 2020

Hi Rob,

I've tried implementing your suggestions and here's what I've found:

  1.   the line "show_TRho_Profile_eos_regions = .true." doesn't output any graph. I think it's because im using a cluster.
  2.  ive attached the entropy profiles from the hydrosimulation and the entropy profile from a default run of wd_cool_0.6M so you can have a look.
  3.  the eos used in the hydrosimulation was the helmholtz eos without coulomb corrections. The temperatures within the white dwarf range from 10**4 to 10**8 so i tried adding the following line and removing the lines :set_HELM_OPAL_lgTs = .true.
      logT_all_HELM = 4d0
      logT_all_OPAL = 3d0
but it doesnt look like it made much of a difference. Perhaps I've missed something or I've this incorrectly?
  4.  I tried relaxing the composition (which I also want to do) first, this works for a while before it runs into the same problem as with entropy relaxation.
  5.  I've also tried reducing the time step limit and max number of backups in a row but I still run into the same problems.


From: Rob Farmer <r.j.farmer at uva.nl>
Sent: 08 September 2020 14:46
To: Conhye, Akaash (UG - Physics) <ac01283 at surrey.ac.uk>
Cc: mesa-users at lists.mesastar.org <mesa-users at lists.mesastar.org>
Subject: Re: [Mesa-users] relaxing entropy


Retries and backups are telling you that mesa is struggling to make the change requested for that step of the entropy relax process. If you look in a T-rho plot with

show_TRho_Profile_eos_regions = .true.

enabled, does it look like the model is crossing any EOS boundaries when it crashes?

How different is your new entropy profile compared with the starting one for the wd? The bigger the difference the harder it will be.

How "close" is the EOS in mesa (for WD's) to what was used in the hydro simulation? The bigger the difference the harder it will be. Remember MESA's eos is a composite of several sources, different parts of a star may be using different EOS's.

> tried using the one provided in the "relax_composition_j_entropy" template to see what would happen.

The entropy profile for relax_composition_j_entropy describes a 10 solar mass TAMS star so that is not going to look like a 0.6Msun WD. So i'm not surprised that starting from a WD and trying to turn it into a 10Msun star fails.


On Tue, 8 Sep 2020 at 13:36, Akaash Conhye via Mesa-users <mesa-users at lists.mesastar.org<mailto:mesa-users at lists.mesastar.org>> wrote:
Hi all,

I've been trying to relax a white dwarf's entropy profile (obtained from hydrodynamic simulations). The template I used was wd_cool_0.6M. To the file inlist_wd_cool_0.6M I've added the following lines:

      relax_initial_entropy = .true.
      max_steps_to_relax_entropy = 1000
      timescale_for_relax_entropy = 1d-9 ! in years
      max_dt_for_relax_entropy = 1d-8 ! in years
      num_timescales_for_relax_entropy = 100
      relax_entropy_filename = 'entropy_unrlx.dat'

Where entropy_unrlx.dat is my entropy profile. Upon running, here is the output on my terminal:

read inlist_wd_cool_0.6M
                             mass_fraction_limit_for_PC    1.0000000000000000D-03
                                       logRho1_PC_limit    2.9990000000000001D+00
                                       logRho2_PC_limit    2.7999999999999998D+00
                                     log_Gamma_all_HELM    1.0000000000000000D+00
                                       log_Gamma_all_PC    1.3010299956000000D+00
                                 PC_Gamma_start_crystal    1.7400000000000000D+02
                                  PC_Gamma_full_crystal    1.7600000000000000D+02
                                               PC_min_Z    9.9900000000000000D-01
load saved model wd_0.6.mod

                    WARNING -- inlist initial_z ignored    1.0000000000000000D-02
                          using saved initial_z instead    2.0000000000000000D-02

 relax_entropy: max_steps_to_use        1000
 retry     129
 retry     129
backup     129
 retry     129
 retry     129
backup     129
 retry     129
 retry     129
                                                    dt    7.7046264609375010D-11
                                     min_timestep_limit    1.0000000000000001D-09

 stopping because of problems dt < min_timestep_limit

 do_relax_initial_entropy ierr          -1
 do_star_job_controls_after ierr          -1
 before_evolve_loop ierr          -1
DATE: 2020-09-08
TIME: 11:00:31

Some things Ive tried to do to fix this problem:

  1.   decreasing min_timestep_limit (by setting it to a smaller value in the controls section of my inlist) so that i don't get the inequality dt<min_timestep_limit. But this doesn't solve the problem as dt continues to get smaller.
  2.  using a different entropy profile. Initially I'd thought that there was something wrong with my entropy profile, so I tried using the one provided in the "relax_composition_j_entropy" template to see what would happen. I got the same error message.

the version of MESA im using is 12115. My operating system is Ubuntu 20.04.1 LTS 64 bit. Im running MESA on a cluster (eureka).


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20200916/459eb86c/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: s.rf.png
Type: image/png
Size: 23038 bytes
Desc: s.rf.png
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20200916/459eb86c/attachment.png>

More information about the Mesa-users mailing list