[Mesa-users] Docker for Windows Update Question
Ian Foley
ifoley2008 at gmail.com
Wed Jul 22 07:38:51 EDT 2020
Thanks heaps for the reply.
Ian
On Wed, 22 Jul 2020 at 21:29, Rob Farmer <r.j.farmer at uva.nl> wrote:
> Hi,
>
> You can skip using docker at all and just go straight for wsl2 on windows.
> Another mesa user tried this and it worked well:
>
> https://lists.mesastar.org/pipermail/mesa-users/2020-June/011500.html
>
> This simplifies things a lot (no more random docker errors!) and makes
> sharing files between windows/mesa a lot easier.
>
> Rob
>
>
> On Wed, 22 Jul 2020 at 13:02, Ian Foley <ifoley2008 at gmail.com> wrote:
>
>> Hi,
>>
>> I noticed that the latest update to Docker includes WSL2 and suggests
>> that using this (which is the new default) rather than Hyper-V on Windows
>> 10 Pro will improve performance. Is there any thought that it might be a
>> good upgrade to the Mesa Docker for Windows option to utilise this option?
>>
>> Kind regards
>> Ian
>>
>>
>> On Sun, 13 Oct 2019 at 19:46, Ian Foley <ifoley2008 at gmail.com> wrote:
>>
>>> Hi,
>>>
>>> I have now solved the problem and thanks Evan for your help which put me
>>> on track to the solution.
>>>
>>> Problem was that changing the Microsoft password deactivated the drive
>>> sharing (I am using drives C and D). Once I changed the password to access
>>> these drives (in docker settings), the problem resolved.
>>>
>>> Kind regards
>>> Ian
>>>
>>>
>>> On Sat, 12 Oct 2019 at 23:58, Ian Foley <ifoley2008 at gmail.com> wrote:
>>>
>>>> Hi,
>>>>
>>>> Having reinstalled windows 10 pro and docker for windows etc, I'm still
>>>> getting this
>>>>
>>>> $ ./win_dockerMESA.sh
>>>> C:/Program Files/Docker/Docker/Resources/bin/docker.exe: Error response
>>>> from dae
>>>> mon: Drive has not been shared.
>>>> See 'C:/Program Files/Docker/Docker/Resources/bin/docker.exe run
>>>> --help'.
>>>> Error: No such container: mesa_dock
>>>> password is mesa
>>>> ssh: connect to host localhost port 6158: Connection refused
>>>> Error response from daemon: Cannot kill container: mesa_dock: No such
>>>> container: mesa_dock
>>>>
>>>> I have successfully run simple docker commands and the hello-world
>>>> container
>>>>
>>>> I ran winpty docker run -it --rm evbauer/mesa_lean:12115.01
>>>>
>>>> and it downloaded mesa version 12115 and entered the container, but
>>>> there was no docker_work directory. The mesa and mesasdk directories were
>>>> there.
>>>>
>>>> It appears the mesa_dock container does not exist or a problem with the
>>>> localhost port 6158.
>>>>
>>>> Does the "drive has not been shared" message imply some internal
>>>> setting in the OS has changed, perhaps as the result of a windows upgrade?
>>>>
>>>> Kind regards
>>>> ian
>>>>
>>>>
>>>>
>>>>
>>>> On Sat, 12 Oct 2019 at 20:10, Ian Foley <ifoley2008 at gmail.com> wrote:
>>>>
>>>>> Hi Evan,
>>>>>
>>>>> Thanks for the comments. As it turns out I was having a problem with
>>>>> logging in and Windows 10 Pro was so tight on security so that eventually I
>>>>> had to re-install my operating system. This means I will have to reinstall
>>>>> Docker. I suspect the problem also impacted Docker.
>>>>>
>>>>> Thanks and Kind regards
>>>>> Ian
>>>>>
>>>>>
>>>>> On Sat, 12 Oct 2019 at 02:45, Evan Bauer <ebauer at physics.ucsb.edu>
>>>>> wrote:
>>>>>
>>>>>> Hi Ian,
>>>>>>
>>>>>> This looks like you’re having a problem with Docker itself, and not
>>>>>> MESA-Docker specifically. Are you able to run simple docker commands? What
>>>>>> happens if you just try something like
>>>>>>
>>>>>> winpty docker run -it --rm evbauer/mesa_lean:12115.01
>>>>>>
>>>>>> Cheers,
>>>>>> Evan
>>>>>>
>>>>>>
>>>>>> On Oct 10, 2019, at 7:53 PM, Ian Foley <ifoley2008 at gmail.com> wrote:
>>>>>>
>>>>>> Hi
>>>>>>
>>>>>> Resending.
>>>>>>
>>>>>> Ignore everything after first message, now deleted. Delete previous
>>>>>> message
>>>>>>
>>>>>> Kind regards
>>>>>> Ian
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Fri, 11 Oct 2019 at 13:49, Ian Foley <ifoley2008 at gmail.com> wrote:
>>>>>>
>>>>>>> Hi,
>>>>>>>
>>>>>>> Getting the following message when running ./win_dockerMESA.sh
>>>>>>>
>>>>>>> $ ./win_dockerMESA.sh
>>>>>>> Unable to find image 'evbauer/mesa_lean:12115.01' locally
>>>>>>> 12115.01: Pulling from evbauer/mesa_lean
>>>>>>> C:/Program Files/Docker/Docker/Resources/bin/docker.exe: image
>>>>>>> operating system
>>>>>>> "linux" cannot be used on this platform.
>>>>>>> See 'C:/Program Files/Docker/Docker/Resources/bin/docker.exe run
>>>>>>> --help'.
>>>>>>> Error: No such container: mesa_dock
>>>>>>> password is mesa
>>>>>>> ssh: connect to host localhost port 6158: Connection refused
>>>>>>> Error response from daemon: Cannot kill container: mesa_dock: No
>>>>>>> such container: mesa_dock
>>>>>>>
>>>>>>> It was working fine yesterday.
>>>>>>>
>>>>>>> Possibly related to a login change into my laptop.
>>>>>>>
>>>>>>> Kind regards
>>>>>>> Ian
>>>>>>>
>>>>>>>
>>>>>>>>
>>>>>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20200722/67dbb345/attachment.htm>
More information about the Mesa-users
mailing list