[Mesa-users] unable to save pulse data to file

Earl Bellinger earlbellinger at gmail.com
Mon Feb 11 16:10:19 EST 2019


Hi Noah Tuchow,

The error message tells you the problem:
> Fortran runtime error: Cannot match namelist object name pulse_info_format
Looking at the controls <http://mesa.sourceforge.net/controls_defaults.html>
page, that field name doesn't exist; try "pulse_data_format" in its place.

Best regards,
Earl


Med venlig hilsen/Kind regards

*Earl Patrick Bellinger, Ph.D. *
Postdoctoral Research Fellow
Stellar Astrophysics Centre
Aarhus University
Web: https://earlbellinger.com


On Mon, Feb 11, 2019 at 10:05 PM TUCHOW, NOAH WOLFE <nxt5109 at psu.edu> wrote:

> Hello everyone,
>
> I'm having a problem saving pulse data to a file in a format that GYRE can
> read. I'm trying to run a standard solar model, save pulse data to a file,
> and run GYRE to generate an oscillation power spectrum. In my inlists I've
> set
>
> &star   save_pulse_data_when_terminate = .true.   save_pulse_data_filename = '1Msun_model.mesa'
>
> /
> &controls   pulse_info_format = ‘GYRE'/
>
> but when I run mesa, I get the error message:
>
> Failed while trying to read control namelist file: inlist_1msun
> Perhaps the following runtime error message will help you find the problem.
>
> At line 1898 of file ../private/ctrls_io.f90 (unit = 29, file = 'inlist_1msun')
> Fortran runtime error: Cannot match namelist object name pulse_info_format
>
> Error termination. Backtrace:
> #0  0x7fc482116dec in finalize_transfer
> 	at /root/mesasdk-src/gcc/libgfortran/io/transfer.c:3891
> #1  0x48643f in __ctrls_io_MOD_read_controls_file
> 	at ../private/ctrls_io.f90:1898
> #2  0x486678 in __ctrls_io_MOD_read_controls_file
> 	at ../private/ctrls_io.f90:1937
> #3  0x4868f7 in __ctrls_io_MOD_read_controls
> 	at ../private/ctrls_io.f90:1854
> #4  0x486965 in __ctrls_io_MOD_do_one_setup
> 	at ../private/ctrls_io.f90:1824
> #5  0x4317d5 in __run_star_support_MOD_before_evolve_loop
> 	at ../job/run_star_support.f90:279
> #6  0x4321d8 in __run_star_support_MOD_run1_star
> 	at ../job/run_star_support.f90:98
> #7  0x416ae6 in __run_star_MOD_do_run_star
> 	at /data/nxt5109/mesa-r10398/star/job/run_star.f:26
> #8  0x416b89 in run
> 	at ../src/run.f:16
> #9  0x416bc0 in main
> 	at ../src/run.f:2
>
>
> The model runs fine when I don't try to save pulse data, and GYRE appears
> to be working properly when used as the oscillation code in the astero
> search module. I've attached my inlists and the model file I'm loading from
> below, and I'm running mesa r10398 on linux. Does anyone have any ideas
> about how I can get rid of this error and save pulse data?
>
> Thanks,
> Noah Tuchow
>
>
> Noah Tuchow Penn State University Department of Astronomy and Astrophysics 532C
> Davey Lab University Park, PA 16802
>
> _______________________________________________
> mesa-users at lists.mesastar.org
> https://lists.mesastar.org/mailman/listinfo/mesa-users
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20190211/df2dc777/attachment.html>


More information about the Mesa-users mailing list