[Mesa-users] Problems with C compiller during MESA installation of crlibm

Bergerson Van Hallen bergersonvanhallen at gmail.com
Thu Feb 7 10:35:09 EST 2019

Hi! In the next items of my problems, I'll provide the following
information in which I read from post a question to mesa-users:

1- MESA version: mesa-r10398;

2- Are you using the MESA SDK? Yes.
     If so, what version? The version is mesasdk-x86_64-linux-20180822.

3- Describe your computer: Ubuntu 18.04.1 LTS, Memory 3,8 GiB, Processor
Intel® Core™ i3-2310M CPU @ 2.10GHz × 4, Graphics NVD9, GNOME 3.28.2, OS
type 64-bit, Disk 487,9 GB

4- What is the output of each of the following commands?

    uname -a --> Linux bergerson 4.15.0-45-generic #48-Ubuntu SMP Tue
Jan 29 16:28:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

    gfortran -v --> Using built-in specs.
Target: x86_64-pc-linux-gnu
Configured with: /root/mesasdk-src/gcc/configure CC=gcc
--build=x86_64-pc-linux-gnu --prefix=/root/mesasdk
--with-gmp=/root/mesasdk --with-mpfr=/root/mesasdk
--with-mpc=/root/mesasdk --enable-languages=c,c++,fortran
--disable-multilib --disable-nls --disable-libsanitizer
Thread model: posix
gcc version 7.2.0 (GCC)

  echo $MESASDK_ROOT --> /home/bergerson/mesasdk

  echo $PATH -->

  echo $MESA_DIR --> /home/bergerson/MESA/mesa-r10398

5- What is the error message you recieved?

   The build.log file was attached in this e-mail. But the error
message that I was received is ./build_and_test FAILED

     in /home/bergerson/MESA/mesa-r10398/crlibm/crlibm and
/home/bergerson/MESA/mesa-r10398/crlibm, i.e., in

     But I don't have tmp.txt file nor tester.log file, these files
doesn't exist. The tester program does not exist, and state
    message in terminal is "Ambiguous output redirect", after run the
tester program: ./tester 2>&1 | tee tester.log.

6 - Why do I get the error “C compiler cannot create executables”?

 I know that my problem in installation of MESA is about C compiler. So,
after I received the error:

configure: error: C compiler cannot create executables
See `config.log' for more details.

I tried fix the trouble with the commands:

GCC_VERSION=`gcc --version | grep ^gcc | sed 's/^.* //g'`

 But the error persists, and I don't know what can I do for have a normal
installation of MESA. In this e-mail
 I also attached the file$MESA_DIR/crlibm/crlibm/config.log for analyze.
Please, I need your help MESA team!

I tried fix the trouble with reinstallation of the gcc, but the error
persists too.

Thank you in advance!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20190207/27a1ddac/attachment.html>

More information about the Mesa-users mailing list