[Mesa-users] Could not clone repository for MESA Docker

Evan Bauer ebauer at physics.ucsb.edu
Mon Jun 4 17:53:14 EDT 2018


For the mesa-users record, the solution seems to have been completely removing the mesa-machine and starting over. Not sure what caused the initial problem, but things appear to be working now.

export MACHINE_STORAGE_PATH=C:\\docker
docker-machine rm mesa-machine


Cheers,
Evan




> On Jun 4, 2018, at 12:34 PM, Evan Bauer <ebauer at physics.ucsb.edu> wrote:
> 
> Ok, I’m stumped for now. I’ll take this off list until we find a solution. You’ll hear from me more in a minute.
> 
> Evan
> 
> 
>> On Jun 4, 2018, at 12:29 PM, Nicholas Proietti <nproiett at oswego.edu <mailto:nproiett at oswego.edu>> wrote:
>> 
>> Hi Evan,
>> 
>> After running:
>> 
>> export MACHINE_STORAGE_PATH=C:\\docker <>
>> 
>> I got the following log:
>> 
>> -----------------------------------------------------------------
>> Regenerate TLS machine certs?  Warning: this is irreversible. (y/n): y
>> Regenerating TLS certificates
>> Waiting for SSH to be available...
>> Too many retries waiting for SSH to be available.  Last error: Maximum number of retries (60) exceeded
>> -----------------------------------------------------------------
>> 
>> Nick
>> 
>> 
>> On Mon, Jun 4, 2018 at 2:23 PM, Evan Bauer <ebauer at physics.ucsb.edu <mailto:ebauer at physics.ucsb.edu>> wrote:
>> Hi Nick,
>> 
>> My bad. Your environment needs to be told where to look for docker-machine first. Try this:
>> 
>> export MACHINE_STORAGE_PATH=C:\\docker <>
>> docker-machine regenerate-certs mesa-machine
>> ./win_home_dockerMESA.sh
>> 
>> Cheers,
>> Evan
>> 
>> 
>>> On Jun 4, 2018, at 8:24 AM, Nicholas Proietti <nproiett at oswego.edu <mailto:nproiett at oswego.edu>> wrote:
>>> 
>>> Hi Evan,
>>> 
>>> This is the log I got from running the command: docker-machine regenerate-certs mesa-machine
>>> 
>>> -------------------------------------------------------------------------------
>>> docker-machine regenerate-certs mesa-machine
>>> Regenerate TLS machine certs?  Warning: this is irreversible. (y/n): y
>>> Regenerating TLS certificates
>>> Docker machine "mesa-machine" does not exist. Use "docker-machine ls" to list machines. Use "docker-machine create" to add a new one.
>>> -------------------------------------------------------------------------------
>>> 
>>> Here is the log I got after running the command: ./win_home_dockerMESA.sh
>>> 
>>> -------------------------------------------------------------------------------
>>> C:\docker
>>> Starting "mesa-machine"...
>>> (mesa-machine) Check network to re-create if needed...
>>> (mesa-machine) Windows might ask for the permission to configure a dhcp server. Sometimes, such confirmation window is minimized in the taskbar.
>>> (mesa-machine) Waiting for an IP...
>>> Machine "mesa-machine" was started.
>>> Waiting for SSH to be available...
>>> Detecting the provisioner...
>>> Started machines may have new IP addresses. You may need to re-run the `docker-machine env` command.
>>> MESA MACHINE STARTED
>>> Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host "192.168.99.100:2376 <http://192.168.99.100:2376/>": x509: certificate is valid for 192.168.99.101, not 192.168.99.100
>>> You can attempt to regenerate them using 'docker-machine regenerate-certs [name]'.
>>> Be advised that this will trigger a Docker daemon restart which might stop running containers.
>>> d12dd07195ae24f953f50771b488c03ddd0e3ac0039cf0b3ae417b270b312006
>>> error during connect: Get https://192.168.99.100:2376/v1.37/containers/mesa_dock/json <https://192.168.99.100:2376/v1.37/containers/mesa_dock/json>: x509: certificate is valid for 192.168.99.101, not 192.168.99.100
>>> password is tcuser
>>> docker at 192.168.99.100 <mailto:docker at 192.168.99.100>'s password:
>>> password is mesa
>>> ssh_exchange_identification: Connection closed by remote host
>>> error during connect: Post https://192.168.99.100:2376/v1.37/containers/mesa_dock/kill?signal=KILL <https://192.168.99.100:2376/v1.37/containers/mesa_dock/kill?signal=KILL>: x509: certificate is valid for 192.168.99.101, not 192.168.99.100
>>> Stopping "mesa-machine"...
>>> Connection to 192.168.99.100 closed by remote host.
>>> Machine "mesa-machine" was stopped.
>>> -------------------------------------------------------------------------------
>>> 
>>> Best,
>>> Nick
>>> 
>>> 
>>> On Sun, Jun 3, 2018 at 7:34 PM, Evan Bauer <ebauer at physics.ucsb.edu <mailto:ebauer at physics.ucsb.edu>> wrote:
>>> Hi Nick,
>>> 
>>> This one is new to me. Try running the following commands and let me know what happens:
>>> 
>>> 	docker-machine regenerate-certs mesa-machine
>>> 	./win_home_dockerMESA.sh
>>> 
>>> Cheers,
>>> Evan
>>> 
>>> 
>>> 
>>>> On Jun 3, 2018, at 8:43 AM, Nicholas Proietti <nproiett at oswego.edu <mailto:nproiett at oswego.edu>> wrote:
>>>> 
>>>> Hi Evan,
>>>> 
>>>> After successfully cloning the repository I tried to start the container running the following command in my MESA-Docker directory:
>>>> 
>>>> ---------------------------------------------------------------------------
>>>> ./win_home_dockerMESA.sh
>>>> 
>>>> ---------------------------------------------------------------------------
>>>> 
>>>> Unfortunately, I got the following log after entering the command. I was not prompted to enter the second password:
>>>> 
>>>> ---------------------------------------------------------------------------
>>>> $ ./win_home_dockerMESA.sh
>>>> C:\docker
>>>> Starting "mesa-machine"...
>>>> (mesa-machine) Check network to re-create if needed...
>>>> (mesa-machine) Windows might ask for the permission to configure a dhcp server. Sometimes, such confirmation window is minimized in the taskbar.
>>>> (mesa-machine) Waiting for an IP...
>>>> Machine "mesa-machine" was started.
>>>> Waiting for SSH to be available...
>>>> Detecting the provisioner...
>>>> Started machines may have new IP addresses. You may need to re-run the `docker-machine env` command.
>>>> MESA MACHINE STARTED
>>>> Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host "192.168.99.100:2376 <http://192.168.99.100:2376/>": x509: certificate is valid for 192.168.99.101, not 192.168.99.100
>>>> You can attempt to regenerate them using 'docker-machine regenerate-certs [name]'.
>>>> Be advised that this will trigger a Docker daemon restart which might stop running containers.
>>>> b2381d2c74c4135a35142286ff7921da5e7e8679d9ce7f6ad5e3546a59c242be
>>>> error during connect: Get https://192.168.99.100:2376/v1.37/containers/mesa_dock/json <https://192.168.99.100:2376/v1.37/containers/mesa_dock/json>: x509: certificate is valid for 192.168.99.101, not 192.168.99.100
>>>> password is tcuser
>>>> docker at 192.168.99.100 <mailto:docker at 192.168.99.100>'s password:
>>>> password is mesa
>>>> ssh_exchange_identification: Connection closed by remote host
>>>> error during connect: Post https://192.168.99.100:2376/v1.37/containers/mesa_dock/kill?signal=KILL <https://192.168.99.100:2376/v1.37/containers/mesa_dock/kill?signal=KILL>: x509: certificate is valid for 192.168.99.101, not 192.168.99.100
>>>> Stopping "mesa-machine"...
>>>> Connection to 192.168.99.100 closed by remote host.
>>>> Machine "mesa-machine" was stopped.
>>>> ---------------------------------------------------------------------------
>>>> 
>>>> Nick
>>>> 
>>>> 
>>>> 
>>>> On Sat, Jun 2, 2018 at 5:58 PM, Nicholas Proietti <nproiett at oswego.edu <mailto:nproiett at oswego.edu>> wrote:
>>>> Hi Evan,
>>>> 
>>>> After I typed mkdir test_dir, I got the following message:
>>>> 
>>>> -------------------------------------------------------------------------------------
>>>> mkdir: cannot create directory ‘test_dir’: Permission denied
>>>> -------------------------------------------------------------------------------------
>>>> 
>>>> I was more successful though in executing the clone command in ~/Desktop, as I got the following message:
>>>> 
>>>> -------------------------------------------------------------------------------------
>>>> Cloning into 'MESA-Docker'...
>>>> remote: Counting objects: 252, done.
>>>> Receiving objects:  59% (149/252)    0 (delta 0), pack-reused 252
>>>> Receiving objects: 100% (252/252), 74.24 KiB | 1.12 MiB/s, done.
>>>> Resolving deltas: 100% (148/148), done.
>>>> -------------------------------------------------------------------------------------
>>>> 
>>>> Thanks,
>>>> Nick
>>>> 
>>>> 
>>>> 
>>>> On Sat, Jun 2, 2018 at 3:43 PM, Evan Bauer <ebauer at physics.ucsb.edu <mailto:ebauer at physics.ucsb.edu>> wrote:
>>>> Hi Nick,
>>>> 
>>>> It looks like you don’t have write permission for the location where you’re trying to clone the repository. What happens if you run something like “mkdir test_dir”? Maybe try navigating to the desktop (“cd ~/Desktop”) and executing the clone command there?
>>>> 
>>>> Cheers,
>>>> Evan
>>>> 
>>>>> On Jun 2, 2018, at 9:50 AM, Nicholas Proietti via Mesa-users <mesa-users at lists.mesastar.org <mailto:mesa-users at lists.mesastar.org>> wrote:
>>>>> 
>>>>> Hello,
>>>>> 
>>>>> I am attempting to install MESA in a Docker on Windows 10 Home, Version 1803 on the Acer Aspire V3-551-8469. After installing the prerequisites (Xming, Git Bash) and the Docker Toolbox, I attempted to begin setup by cloning the repository using
>>>>> 
>>>>> ----------------------------------------------------------------------------
>>>>> git clone https://github.com/evbauer/MESA-Docker.git <https://github.com/evbauer/MESA-Docker.git>
>>>>> ----------------------------------------------------------------------------
>>>>> 
>>>>> Unfortunately, I received the message:
>>>>> 
>>>>> ------------------------------
>>>>> ------------------------------
>>>>> ----------------
>>>>> fatal: could not create work tree dir 'MESA-Docker': Permission denied
>>>>> 
>>>>> ----------------------------------------------------------------------------
>>>>> 
>>>>> Any suggestions on how I could solve this would be greatly appreciated.
>>>>> 
>>>>> 
>>>>> Nick
>>>>> -- 
>>>>> Nicholas Proietti
>>>>> Undergraduate Major in Physics
>>>>> State University of New York at Oswego
>>>>> nproiett at oswego.edu <mailto:nproiett at oswego.edu> | 518-952-5002
>>>>> 
>>>>> _______________________________________________
>>>>> mesa-users at lists.mesastar.org <mailto:mesa-users at lists.mesastar.org>
>>>>> https://lists.mesastar.org/mailman/listinfo/mesa-users <https://lists.mesastar.org/mailman/listinfo/mesa-users>
>>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> -- 
>>>> Nicholas Proietti
>>>> Undergraduate Major in Physics
>>>> State University of New York at Oswego
>>>> nproiett at oswego.edu <mailto:nproiett at oswego.edu> | 518-952-5002
>>>> 
>>>> 
>>>> 
>>>> 
>>>> -- 
>>>> Nicholas Proietti
>>>> Undergraduate Major in Physics
>>>> State University of New York at Oswego
>>>> nproiett at oswego.edu <mailto:nproiett at oswego.edu> | 518-952-5002
>>>> 
>>> 
>>> 
>>> 
>>> 
>>> -- 
>>> Nicholas Proietti
>>> Undergraduate Major in Physics
>>> State University of New York at Oswego
>>> nproiett at oswego.edu <mailto:nproiett at oswego.edu> | 518-952-5002
>>> 
>> 
>> 
>> 
>> 
>> -- 
>> Nicholas Proietti
>> Undergraduate Major in Physics
>> State University of New York at Oswego
>> nproiett@ <mailto:nproiett at oswego.edu>oswego.edu <mailto:nproiett at oswego.edu> | 518-952-5002
>> 
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20180604/35bd3825/attachment.html>


More information about the Mesa-users mailing list