[Mesa-users] "build_and_test FAILED" error on Windows Linux Subsystem

Rob Farmer r.j.farmer at uva.nl
Mon Apr 16 13:11:26 EDT 2018


Hi
This is a known issue but currently there is no fix. Your best bet for
running Mesa on windows is to use Mesa docker:

https://github.com/evbauer/MESA-Docker

Rob

On Mon, 16 Apr 2018, 19:01 Márcio Catelan via Mesa-users, <
mesa-users at lists.mesastar.org> wrote:

> Hi,
>
> I need your help because I am running into a "build_and_test FAILED" error
> while installing MESA on my system. Here are some details:
>
> MESA Version: 103985
> MESA SDK version: 20180127
> Operating system: Windows 10 Professional, Build 16299
> Windows Linux Subsystem
>
> My machine is a Dell Precision 5510 notebook with 32 GB RAM and plenty of
> disk space available.
>
> Below is some of the output that is produced by the indicated commands:
>
> uname -a
> Linux ESMERALDA-PLUS 4.4.0-43-Microsoft #1-Microsoft Wed Dec 31 14:42:53
> PST 2014 x86_64 x86_64 x86_64 GNU/Linux
>
> gfortran -v
> Using built-in specs.
> COLLECT_GCC=/home/mcatelan/mesasdk/bin/gfortran.exec
>
> COLLECT_LTO_WRAPPER=/home/mcatelan/mesasdk/bin/../libexec/gcc/x86_64-pc-linux-gnu/7.2.0/lto-wrapper
> Target: x86_64-pc-linux-gnu
> Configured with: /root/mesasdk-src/gcc/configure CC=gcc
> --build=x86_64-pc-linux-gnu --prefix=/root/mesasdk --with-gmp=/root/mesasdk
> --with-mpfr=/root/mesasdk --with-mpc=/root/mesasdk
> --enable-languages=c,c++,fortran
>  --disable-multilib --disable-nls --disable-libsanitizer
> --enable-clocale=generic
> Thread model: posix
> gcc version 7.2.0 (GCC)
>
> echo $MESASDK_ROOT
> /home/mcatelan/mesasdk
>
> echo $PATH
> /home/mcatelan/mesasdk/bin:/home/mcatelan/mesasdk/bin:/home/mcatelan/mesasdk/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/mnt/c/Program
> Files/Docker/Docker/resources/bin:/mnt/c/ProgramDat
> a/Oracle/Java/javapath_target_611486765:/mnt/c/Program Files
> (x86)/Intel/iCLS Client:/mnt/c/Program Files/Intel/iCLS
> Client:/mnt/c/Windows/System32:/mnt/c/Windows:/mnt/c/Windows/System32/wbem:/mnt/c/Windows/System32/WindowsPowerShell/v1
> .0:/mnt/c/Program Files/MiKTeX 2.9/miktex/bin/x64:/mnt/c/Program Files
> (x86)/Intel/Intel(R) Management Engine Components/DAL:/mnt/c/Program
> Files/Intel/Intel(R) Management Engine Components/DAL:/mnt/c/Program Files
> (x86)/Intel/Intel(R)
> Management Engine Components/IPT:/mnt/c/Program Files/Intel/Intel(R)
> Management Engine
> Components/IPT:/mnt/c/PROGRA~2/TableCurve3Dv4.0:/mnt/c/PROGRA~2/TableCurve2Dv5.01:/mnt/c/Program
> Files/Git/cmd:/mnt/c/Users/marca/AppData/Local/Micro
> soft/WindowsApps:/snap/bin
>
> echo $MESA_DIR
> /home/mcatelan/mesa-r10398
>
> The error message that I receive (which I confirmed is reproducible) is as
> follows:
>
> gfortran -fopenmp -o ../sample sample_eos.o -L../../make -leos
> -L../../../lib -lchem -linterp_2d -linterp_1d -lnum -lf2crlibm -lcrlibm
> -lmtx -lconst -lutils `mesasdk_lapack_link` `mesasdk_blas_link`
> `mesasdk_hdf5_link`
> ../utils/build_and_test_parallel: line 56: 12813 Segmentation fault
> (core dumped) ./test_quietly &> test_quietly.txt
>
> /home/mcatelan/mesa-r10398/eos/test
> FAILED
>
> I attach the file build.log, which is output once I run the sequence
>
> ./clean
> ./install | tee build.log
>
> Your help will be gratefully appreciated!
>
>    --M.C.
>
>
>
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20180416/ebd4a6eb/attachment.html>


More information about the Mesa-users mailing list