[mesa-users] Missing data for Macdonald EoS?

Aaron Dotter aaron.dotter at gmail.com
Mon Feb 27 11:49:20 EST 2017

Hi Warrick,

The error message is caused by leftover code in MESA from an experiment
(the _2_ is experimental).  I ran into the same problem when trying to use
a different set of tables.

In the next development cycle, I'll be removing the _2_ file requirements
and then you'll be able to try the MacDonald tables again.  I can let you
know when a new version is ready to try.

Jim MacDonald's EOS tables were brought in, as far as I recall, to
completement the current OPAL/SCVH EOS tables at higher Z (=0.2 and 1.0).
The OPAL EOS is only provided at Z=0, 0.02, and 0.04.  The full set of
MacDonald tables were provided for completeness.


On Mon, Feb 27, 2017 at 8:39 AM, Warrick Ball <wball at bison.ph.bham.ac.uk>

> Hi everyone,
> I've been calibrated some solar models and was interested to try a
> different equation of state option in r9575.  I had a look on the forums
> and saw [1] that suitable prefixes can be found by listing
> ls $MESA_DIR/data/eos*
> I tried the 'macdonald' option but immediately ran into issues, after
> which I found that there's a separate export script for the Macdonald data
> at
> $MESA_DIR/eos/build_macdonald_DTdata_and_export
> and
> $MESA_DIR/eos/build_macdonald_PTdata_and_export
> I ran both of those and then tried a simple test run (just add
> eos_file_prefix = 'macdonald' to a new $MESA_DIR/star/work/ directory).
> It starts by caching some EoS data. e.g.
> write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-
> eosDT_00z60x.bin
> write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-
> eosDT_00z80x.bin
> write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-
> eosDT_02z60x.bin
> write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-
> eosDT_02z80x.bin
> write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-
> eosDT_04z60x.bin
> write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-
> eosDT_04z80x.bin
> but then halts with
>   load eos tables /home/wball/mesa/9575/data/eosDT_2_data/macdonald-eosDT_
> 2_00z60x.data
> FATAL ERROR: missing or bad eos data.
> Please update by removing the directories mesa/data/eos*_data and
> rerunning the mesa ./install script.
> I duly followed those instructions, which roughly took me back to the
> beginning. i.e. had to manually build_and_export the Macdonald data and
> got the same output.
> Is the Macdonald EoS no longer supported in MESA?  In fact, are any other
> EoS's supported?  I'll have another go at using HELM throughout the star
> now.
> Cheers,
> Warrick
> [1] https://sourceforge.net/p/mesa/mailman/message/35327771/
> ------------
> Warrick Ball
> Postdoc, School of Physics and Astronomy
> University of Birmingham, Edgbaston, Birmingham B15 2TT
> wball at bison.ph.bham.ac.uk
> +44 (0)121 414 4552
> ------------------------------------------------------------
> ------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> mesa-users mailing list
> mesa-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/mesa-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20170227/e475c635/attachment.html>

More information about the Mesa-users mailing list