[mesa-users] Missing data for Macdonald EoS?

Warrick Ball wball at bison.ph.bham.ac.uk
Mon Feb 27 11:39:51 EST 2017

Hi everyone,

I've been calibrated some solar models and was interested to try a 
different equation of state option in r9575.  I had a look on the forums 
and saw [1] that suitable prefixes can be found by listing

ls $MESA_DIR/data/eos*

I tried the 'macdonald' option but immediately ran into issues, after 
which I found that there's a separate export script for the Macdonald data 




I ran both of those and then tried a simple test run (just add 
eos_file_prefix = 'macdonald' to a new $MESA_DIR/star/work/ directory). 
It starts by caching some EoS data. e.g.

write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-eosDT_00z60x.bin
write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-eosDT_00z80x.bin
write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-eosDT_02z60x.bin
write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-eosDT_02z80x.bin
write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-eosDT_04z60x.bin
write /home/wball/mesa/9575/data/eosDT_data/cache/macdonald-eosDT_04z80x.bin

but then halts with

  load eos tables /home/wball/mesa/9575/data/eosDT_2_data/macdonald-eosDT_2_00z60x.data

FATAL ERROR: missing or bad eos data.
Please update by removing the directories mesa/data/eos*_data and rerunning the mesa ./install script.

I duly followed those instructions, which roughly took me back to the 
beginning. i.e. had to manually build_and_export the Macdonald data and 
got the same output.

Is the Macdonald EoS no longer supported in MESA?  In fact, are any other 
EoS's supported?  I'll have another go at using HELM throughout the star 


[1] https://sourceforge.net/p/mesa/mailman/message/35327771/

Warrick Ball
Postdoc, School of Physics and Astronomy
University of Birmingham, Edgbaston, Birmingham B15 2TT
wball at bison.ph.bham.ac.uk
+44 (0)121 414 4552

More information about the Mesa-users mailing list