[mesa-users] Problem binding GYRE5.0rc1 in Mesa r9575

Aaron Dotter aaron.dotter at gmail.com
Wed Apr 5 19:01:32 EDT 2017


Hi Alfred,

Just a guess!  Did you do a ./clean in mesa/star before linking with the
new version of GYRE?  It might be that your star module was built against
the old version and is now confused by the new.

Aaron

On Wed, Apr 5, 2017 at 6:05 PM, <alfred at gautschy.ch> wrote:

>
> Dear Blackbelters,
>
> recently I decided to upgrade to r9575 of Mesa; the undertaking was
> painless and successful -- using GYRE 4.4, which comes with the Mesa
> release. Motivated by Warrick's report on GYRE complaints I felt
> forced to update also GYRE to 5.0rc1. Installing this latest GYRE
> version in standalone mode (i.e. make in $GYRE_DIR) was successful and
> all tests were passed successfully.  However, going back to the mesa
> directory and doing a new ./install to bind GYRE to Mesa so that it
> can be called from within Mesa fails; and it just beats me why that
> happens.
>
> Here some lines of the terminal output during the installation
> procedure in the mesa directory:
>
> ...
> export
> done
>
> mesa/star has been built, tested, and exported.
>
> ************************************************
>
> /home/alfred/StarWare/Mesa/mesa/gyre
> building gyre package.
>
> gyre/
> gyre/bin/
> ...
> ...
> Unescaped left brace in regex is deprecated, passed through in regex;
> marked by <-- HERE in m/\G{ <-- HERE / at
> /home/alfred/mesasdk/bin/fpx3 line 261.
> FC gyre_soln_seg.f90
> FC gyre_soln.f90
> FC gyre_evol_model.f90
> gyre_evol_model.f90:2327:13:
>
>         where (pt%x /= 0._WP)
>               1
> Error: WHERE/ELSEWHERE clause at (1) requires a LOGICAL array
> gyre_evol_model.f90:2328:9:
>
>            f = SQRT(MAX(As/c_1, 0._WP))/pt%x
>           1
> Error: WHERE assignment target at (1) has inconsistent shape
> gyre_evol_model.f90:2330:9:
>
>            f = 0._WP
>           1
> Error: WHERE assignment target at (1) has inconsistent shape
> gyre_evol_model.f90:2334:25:
>
>                   integrate(pt%x, f)
>                           1
> Error: There is no specific function for the generic 'integrate' at (1)
> gyre_evol_model.f90:2299:25:
>
>                   integrate(pt%x, f)
>                           1
> Error: There is no specific function for the generic 'integrate' at (1)
> makefile:73: die Regel für Ziel „gyre_evol_model.mod“ scheiterte
> make: *** [gyre_evol_model.mod] Fehler 1
>
> /home/alfred/StarWare/Mesa/mesa/gyre/make
> FAILED
>
>
> What beats me is that apparently, in the standalone installation,
> compiling/linking of *all* routines was successful.
>
> In terms of machine, I'm running ubuntu 16.04 LTS and the latest
> release of mesasdk.
>
> Any hint or help is appreciated.
>
> Thanks, Alfred
>
>
>
> ------------------------------------------------------------
> ------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> mesa-users mailing list
> mesa-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/mesa-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20170405/3f281b6a/attachment.html>


More information about the Mesa-users mailing list