[mesa-users] PGSTAR/PGPLOT Problems (XErrorEvent: BadDrawable)

Josiah Schwab jwschwab at berkeley.edu
Tue Feb 10 17:38:07 EST 2015

Hi All,

> I have been having intermittent problems with PGSTAR windows over ssh.
> My PGSTAR windows die with the message
>   PGPLOT /xw: XErrorEvent: BadDrawable (invalid Pixmap or Window parameter)
>   PGPLOT /xw: Major opcode of failed request: 70
>   PGPLOT /xw: Lost PGPLOT window 1.
> but the MESA run itself continues as normal.

Here is some updated information about this problem.  I am currently
using mesa-r7385 and the December 11, 2014 MESA SDK (for Linux), but
have had the same problem with all other versions that I've tried,
including r5118, r6596, and the July 2014 SDK.

The PGSTAR window disappears after a short (~minutes) amount of time.
The exact time varies, but it has always vanished in less than 5 min.
MESA does not have to be taking timesteps -- it can be paused -- for
this to occur.

This only happens when running MESA on the compute nodes of one of the
clusters I am using.  It does not happen on the head nodes of the same
cluster, nor on the compute nodes of a different cluster.

This is not appear to be directly related to X11 forwarding, because if
I start an xterm on the compute node and run MESA there, only the PGPLOT
window disappears.  The xterm window remains.

It is not related to a specific internet connection.  I have tried a mix
of wired and wireless connections in multiple physical locations.

I'm running Linux and the latest X.  My cubicle-mates can all reproduce
this: they're running a range of versions of OS X and XQuartz.

Our cluster's support team cannot reproduce it.  I cannot reproduce it
on cluster's support team's machine.

A PGPLOT window generated by a trivial PGPLOT example program does not
disappear.  No other (non-pgplot) X11 window I tried disappeared.

I could go on...it's been a fun time :)

My purpose in this message is mostly to archive the description of this
problem, in case someone else encounters it.  We have not identified a
solution.  I'll let you know if I ever learn more.


Step 0: Download and unpack the test-x11 directory.

    tar xf test-x11.tgz

  This is the test problem contained in the star/work directory, but
  with only the HR diagram window active and pause = .true. set in
  &pgstar, so that it will pause between each timestep.

Step 1: Start an interactive job on the cluster

    srun --pty --account=<account> --partition=<partition> --qos=<qos> -t 00:30:00 bash -i

Step 2: Set the environment variables that MESA requires.

    export MESA_DIR=/path/to/mesa-r7385
    export MESASDK_ROOT=/path/to/mesasdk
    source $MESASDK_ROOT/bin/mesasdk_init.sh
    export OMP_NUM_THREADS=<n>

Step 3: Start the calculation.  A PGPLOT X11 window will appear.

    cd /path/to/test-x11

  You will see a bunch of terminal output. You can safely ignore it.
  Eventually you will see a line which says

    PGSTAR: paused -- hit RETURN to continue

  and a window showing a simple plot should appear.

Step 4: Wait. The PGPLOT X11 window will disappear.

  If you wait for a few minutes, the window will disappear.

  If you hit return twice, the code will advance two time steps and
  display the error message

    PGPLOT /xw: XErrorEvent: BadDrawable (invalid Pixmap or Window parameter)
    PGPLOT /xw: Major opcode of failed request: 70
    PGPLOT /xw: Lost PGPLOT window 1.

  One time I got a different opcode (63), but it is almost always 70.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: test-x11.tgz
Type: application/x-gtar-compressed
Size: 3554 bytes
Desc: not available
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20150210/147db8a7/attachment.tgz>

More information about the Mesa-users mailing list