[mesa-users] Running MESA on Mavericks (library problem)

Josiah Schwab jwschwab at berkeley.edu
Thu Nov 14 20:25:57 EST 2013


Hi Sibilla,

> dyld: Library not loaded: /sw/lib/libxml2.2.dylib
>
> Referenced from: /sw/lib/libneon.27.dylib
>
> Reason: Incompatible library version: libneon.27.dylib requires version
> 11.0.0 or later, but libxml2.2.dylib provides version 10.0.0
>
> ----------
>
> Does this difference depend from the library not loaded above?

Almost certainly not.  This looks like your dynamic linker telling you
something is a little wonky in your fink install.  If you "update" fink
(whatever that means in fink-land) I'd imagine that warning will get
taken care of.

> How can I solve this problem?

If you can develop a simple, reproducible test case or at least confirm
that you see the same behavior in a current MESA version, that would be
useful.  (A year old is ancient history at the rate MESA moves.)  Since
this was triggered by an OS upgrade, that may not be easy.

If you have a colleague who still has non-Mavericks OS X and runs MESA,
it would be interesting to see if you can cook something up.  The best
kind of test case is identical MESA/ MESA SDK versions, starting from an
identical model, with an identical inlist, that gives a
platform-dependent result after a single timestep.

To the best of my knowledge, MESA does not presently give bit-for-bit
identical results across different OSes.  During the 2013 summer school,
we demonstrated this presence variation across OSX/Linux.

Best,
Josiah




More information about the Mesa-users mailing list