[mesa-users] RAM issues in sdb_test

sutirtha sengupta sutirtha.sg86 at gmail.com
Thu Jun 27 12:14:39 EDT 2013

I am using MESA (with SDK) on a 64-bit quad-core desktop with 8GB of RAM in
Ubuntu(12.04) framework. I want to test the latest updates to the diffusion
routines (including radiative levitation). I downloaded the OPCD_3.3 data
file from the OP website and installed it to create the data files (in the
mono directory) required by mesa for calculating radiative accelerations.
But I run out of memory (RAM) as soon as mesastar loads the data into
memory i.e. after the screen shows 'reading OP cache file
.../data/kap_data/op_mono_cach.bin'  - I checked the op_mono_cache.bin file
created during the test run (with the sdb test suite in MESA version 4936)
- it is 869MB in size and I have 7GB of RAM free.  I also tried running on
a single thread but still it uses up the whole RAM (and I can hardly kill
the process!). I did not make any changes to the test suite (sdb) and am
using the same inlist (inlist_sdb). Any ideas how to resolve this issue
would help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20130627/1641d2d0/attachment.html>

More information about the Mesa-users mailing list