[mesa-users] pointer error in mtx_support.f

Warrick Ball wball at astro.physik.uni-goettingen.de
Thu Aug 1 06:09:16 EDT 2013


I wouldn't call myself an "active" ifort user: I use the SDK myself. 
However, ifort (versions 13.0 and 12.1) is available on the local systems, 
so I tried compiling MESA using those.  The code compiled successfully 
with both versions.  GCC was version 4.7.0.  Some system details:

> uname -a
Linux gwdu101 2.6.32-358.2.1.el6.x86_64 #1 SMP Tue Mar 12 14:18:09 CDT
2013 x86_64 x86_64 x86_64 GNU/Linux

> cat /etc/issue
Scientific Linux release 6.4 (Carbon)


This was with MESA 5271 (released a few days ago, IIRC).

That said, I tried some test cases and all ultimately failed at runtime 
because of segmentation faults.  If anyone is interested, I can provide 
more detailed results but I'm just sticking to the SDK myself.


On Tue, 30 Jul 2013, Josiah Schwab wrote:

> Hi Liza,
>> By looking at these error, it seem the compiler which I used ifort 11.1 do
>> not recognize the pointer object in the subroutines inside the
>> mtx_support.f. Do anyone have any idea how to tackle this problem?
> I haven't used ifort with MESA in years -- I switched to the MESA SDK
> and never looked back -- but I think the minimum version of ifort needed
> to build MESA is > 11.
> I don't know whether it's 12 or 13 though.  I seem to recall some posts
> on this list regarding problems with 12, but hopefully an active ifort
> user can weigh in and give you some up-to-date information.
> Best,
> Josiah

Warrick Ball
Postdoc, Institut für Astrophysik Göttingen
wball at astro.physik.uni-goettingen.de
+49 (0) 551 39 5069

More information about the Mesa-users mailing list