[mesa-users] Exterior compilation issue

Julien Dorval dorvaljulien at gmail.com
Sun Oct 7 23:45:32 EDT 2012

To add a bit more info: I'm using version 4522 of MESA, which I compiled
with sdk in the first place (latest version:
mesasdk-x86_64-linux-20120809.tar.gz ). I made sure the makefile of the
external work directory was pointing back to the star folder in the
original mesa directory. It really seems to be a compiler issue but I don't
know what's going on here.

Julien Dorval

2012/10/8 Julien Dorval <dorvaljulien at gmail.com>

> Hi,
> I downloaded MESA, compiled it, tried it, everything worked. However when
> I tried setting up a work directory outside the MESA directory, and compile
> it using ./mk I got this:
> make: Warning: File `makefile' has modification time 3.6e+03 s in the
> future
> gfortran -fno-range-check  -fopenmp -fbounds-check -Wuninitialized
> -Warray-bounds -g -ffree-form -x f95-cpp-input
> -I/import/extend2/dorval/MESA/MESA_4522/mesa/include -I/include -c
> ../src/run_star_extras.f
> cc1: error: unrecognized command line option "-Warray-bounds"
> cc1: warning: -Wuninitialized is not supported without -O
> make: *** [run_star_extras.o] Error 1
> The modification time thing is probably due to daylight saving time issue,
> but what exactly caused the error, and how can I fix it ?
> Thanks,
> Julien Dorval
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20121008/c20907a1/attachment.html>

More information about the Mesa-users mailing list