[mesa-users] Exterior compilation issue

Julien Dorval dorvaljulien at gmail.com
Sun Oct 7 22:52:59 EDT 2012


I downloaded MESA, compiled it, tried it, everything worked. However when I
tried setting up a work directory outside the MESA directory, and compile
it using ./mk I got this:

make: Warning: File `makefile' has modification time 3.6e+03 s in the future
gfortran -fno-range-check  -fopenmp -fbounds-check -Wuninitialized
-Warray-bounds -g -ffree-form -x f95-cpp-input
-I/import/extend2/dorval/MESA/MESA_4522/mesa/include -I/include -c
cc1: error: unrecognized command line option "-Warray-bounds"
cc1: warning: -Wuninitialized is not supported without -O
make: *** [run_star_extras.o] Error 1


The modification time thing is probably due to daylight saving time issue,
but what exactly caused the error, and how can I fix it ?

Julien Dorval
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20121008/5b3ca8b4/attachment.html>

More information about the Mesa-users mailing list