[mesa-users] running ./rn gives error

Nikolai nikolai0 at email.com
Thu May 31 09:17:56 EDT 2012

Hi Aaron,

I'm using gfortran.

     initial_Z = 0.0d0

did not work, but setting it to a small positive number did work. I'm 
not determined to evolve a metal-free star, so this solved it for me.

Thanks very much.


On 31.05.2012 13:19, Aaron Dotter wrote:
> Hi Nikolai,
> What compiler are you using?  We used to see this issue particularly 
> with gfortran.
> The error message that you received indicates that MESA tried to set 
> the initial composition of some species in the nuclear network to a 
> (very small) negative number.  That may be because you have
>          initial_Z = 0.00
> which is a real, not a double precision number, so it will add some 
> garbage to initial_Z.  If you try instead
>          initial_Z = 0.0d0
> this could solve the problem.  Otherwise, if you are not determined to 
> evolve a metal-free star, you could set to a small, positive number 
> just to run the example.
> Aaron

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20120531/8f290179/attachment.html>

More information about the Mesa-users mailing list