[mesa-users] svn#3918, Installation hangs

Frank Kahle mesa at fraka-mp.net
Sat Mar 3 05:35:08 EST 2012

Dear All,

I'd like to upgrade from #3251 to #3918 on OS X 10.5.8 PPC, but the  
installation seems to hang when performing

gfortran -fopenmp -o ../test_mpi test_pardiso_stub.o test_klu.o  
test_mtx_support.o test_banded.o test_block_tridiagonal.o  
test_square.o test_square_quad.o test_sparse.o test_mtx_mpi.o \
         -L../../make -lmtx -lmesaklu -framework accelerate  - 
L../../../lib -lutils -lalert

At this point a process tester showed up and seems to hang in an  
indefinite loop:

Sampling process 15348 for 1 seconds with 1 millisecond of run time  
between samples
Sampling completed, processing symbols...
Analysis of sampling tester (pid 15348) every 1 millisecond
Call graph:
     850 Thread_2503
       850 start
         850 main
           850 MAIN__
             850 __test_square_quad_MOD_do_test_square_quad
               850 __test_square_quad_MOD_test_square_quad1
                 850 qgetrf_
                   850 qgetf2_
                     850 qlamch_
                       850 qlamc2_
                         850 qlamc1_
                           664 __gcc_qadd
                             664 __gcc_qadd
                           123 qlamc1_
                           63 dyld_stub___gcc_qadd
                             63 dyld_stub___gcc_qadd

Total number in stack (recursive counted multiple, when >=5):

Sort by top of stack, same collapsed (when >= 5):
         __gcc_qadd        664
         qlamc1_        123
         dyld_stub___gcc_qadd        63

Since mesa is quite picky with respect to gfortran, I've tried both:  
4.5 and 4.6. Like in #3251 I tried to compile mesa with -framework  
accelerate, because using mesa supplied sources for lapack and blas  
yields a linkage error with respect to where those libraries are to be  
found (MesaSDK isn't available for OS X PPC, is that right?)?

Any ideas?

Kind regards,

More information about the Mesa-users mailing list