[mesa-users] Problem doing "make" in work directory

Linda Strubbe linda at cita.utoronto.ca
Wed Jun 6 11:49:02 EDT 2012

Hi mesa-users,

I'm still trying to get mesa up and running on my machine, and would
appreciate some help :)
After my previous question about installing mesa, I've got it installed now
on my linux desktop (which is running Fedora release 14).  I ran the
"appetizer" successfully.  Now I've made the copy of the work directory,
and am trying to make the executable there, but it isn't working so far.  I
set mesa_dir and mesa_data_dir as instructed in the README file.  But when
I do ./mk, I get the following error:

narwhal.cita.utoronto.ca> ./mk
gfortran -fno-range-check  -fopenmp -fbounds-check -g -I~/mesa/include
-I/opt/mesasdk/include -c -ffree-form ../src/run_star_extras.f
../src/run_star_extras.f:34: Error: Can't open included file
make: *** [run_star_extras.o] Error 1


Maybe I still don't have things linked up correctly somehow?
I don't know if this is relevant, but I saw you suggested to another user
to do ./ck in the mesa/star/test directory for a similar-seeming problem--
I did do that and got no output (which I think means that worked correctly).

Thanks for your help with this!

PS This might seem like a really basic suggestion, but I think on the "How
to use MESA star" webpage, it would be helpful to put the instructions
(that you actually type, or pieces of code) in a fixed-width font like
Courier.  The instruction "./rn" looked to me like "./m" (my officemate
agrees), and I kept getting "./m:  Command not found." until I figured out
that I was just mis-reading the webpage.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20120606/f76aa4c4/attachment.html>

More information about the Mesa-users mailing list