[mesa-users] Installing MESA in Ubuntu (9.10, 10.04 and 12.04) and Fedora Core 8 without root privileges

Max Katz maxpkatz at gmail.com
Sun Jun 3 16:31:58 EDT 2012


Thanks for putting this together. I haven't had to install mesa without
root privileges yet, but I can confirm that every step other than the
LD_LIBRARY_PATH environment variable is all you need for installing it on
Ubuntu *with* root privileges. I do want to point out one minor thing that
occurs if you're using a 32 bit installation of Ubuntu -- step 3 refers to
a slightly different set of directories:

cp -rf /usr/include/i386-linux-gnu/*

This was originally pointed out to me in an earlier set of e-mails
regarding MESA on Ubuntu on this mailing list by M. N. Anandaram.

- Max Katz

On Sun, Jun 3, 2012 at 4:00 PM, Alessandro Patruno <ale.patruno at gmail.com>wrote:

> Hi all,
> I have been trying to install MESA on several Ubuntu systems and I have
> collected some experience that I'd like to share with the community.
> I have prepared a to-do list that one should follow to install the code
> with MESASDK
> in Ubuntu (and Fedora 8) in case you don't have root privileges, which is
> a rather common situation in some
> Universities. I've tried this method in Ubuntu 9.10, 10.04, 12.04 and
> Fedora Core 8
>  and it has always worked.
> The only time you need to be root is when installing the packages
> libx11-dev, libz-dev and tcsh
> (at least in Ubuntu) but then everything can be done without much trouble.
> I don' t know whether what I've prepared is the optimal solution, very
> likely it is not, so please correct me or make your own
> suggestions. I hope this will help even more people to enjoy this
> beautiful code !
> I assume you've downloaded MESA and the MESASDK version appropriate for
> your machine architecture.
> 1. Install the system packages: libx11-dev, libz-dev and tcsh
> You need to have root privileges in this case (and only in this case).
> This step is necessary in Ubuntu, I haven't verified it in Fedora Core 8.
> In Ubuntu type in a shell:
> sudo apt-get install libz-dev libx11-dev tcsh
> 2. set the following environmental variables ( I assume you use the bash
> shell, which
> is the default choice in Ubuntu):
> export MESASDK_ROOT=/your_path_to_mesasdk/
> source $MESASDK_ROOT/bin/mesasdk_init.sh
> export OMP_NUM_THREADS=n
> (Set n = number of CPUs you want to use)
> 3. Copy some missing files:
> cp -rf /usr/include/x86_64-linux-gnu/*
> /your_path_to_mesasdk/lib/gcc/x86_64-pc-linux-gnu/4.7.0/include-fixed/
> 4. set environmental variable LD_LIBRARY_PATH:
> export LD_LIBRARY_PATH=/your_path_to_mesasdk/lib/
> 5. Go to your mesa directory (NOT mesasdk)
> and run ./install
> NOTE: You have to re-run point 2 every time you use MESA, but you can
> avoid that by including these three lines in
> your .bashrc or .profile file in your home. Another option (which is the
> one I use) is to prepare a script that you run
> every time before running MESA
> I hope this helps !
> Cheers,
> Alessandro Patruno
> ------------------------------------------------------------------------------
> Live Security Virtual Conference
> Exclusive live event will cover all the ways today's security and
> threat landscape has changed and how IT managers can respond. Discussions
> will include endpoint security, mobile security and the latest in malware
> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> _______________________________________________
> mesa-users mailing list
> mesa-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/mesa-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20120603/4a589a51/attachment.html>

More information about the Mesa-users mailing list