[mesa-users] Problems with TIOGA

Giannotti, Maurizio MGiannotti at mail.barry.edu
Wed Jan 25 13:45:09 EST 2012


Hello Bill,

Thanks for your prompt response.

I did as you said. I copied your files (log42.data and profiles.index) in my LOGS folder, and I ran the command. This is the output that I get:

mesa2 at mesa2:~/Desktop/projects/multi_work/star_profile$ tioga by_mass -m 0
loading /home/mesa2/Desktop/projects/multi_work/star_profile/by_mass.rb
log_mass_frac_ymin -6
write FYI track info
xs.length 1040
xs[0] 2.98962080547118
xs[-1] 1.17545985800201e-07
@xmin
@xmax
@grid_min 0
@grid_max -1
xs[@grid_min] 2.98962080547118
xs[@grid_max] 1.17545985800201e-07
show_by @xaxis_by mass name abundances
no frills false
eval_str  =   abundances(xs, xlabel)
  0  /home/mesa2/Desktop/projects/multi_work/star_profile/profiles_out/Abundances.pdf
mesa2 at mesa2:~/Desktop/projects/multi_work/star_profile$

The output is very similar to what you get, except for the line
 Abundances_figure.pdf

just after eval_str  =   abundances(xs, xlabel)

However, the folder profile_out is empty. If I try to see the output file that is what I get:

home/mesa2/Desktop/projects/multi_work/star_profile/profiles_out/Abundances.pdf
bash: home/mesa2/Desktop/projects/multi_work/star_profile/profiles_out/Abundances.pdf: No such file or directory


Notice that I have UBUNTU and not the latest version of MESA (I still have the version installed around last September).

I am pretty confused about what is going on. Do you think I should try to install the latest version of MESA, reinstall TIOGA, and try again?

Thank you very much for you help.

Maurizio



From: Bill Paxton [mailto:paxton at kitp.ucsb.edu]
Sent: Tuesday, January 24, 2012 10:16 PM
To: Giannotti, Maurizio
Cc: mesa-users at lists.sourceforge.net
Subject: Re: [mesa-users] Problems with TIOGA

Hi Maurizio,

I just checked on my machine.  I did a run in the work directory so that there were files in LOGS.
Then I did cd star_profile and ran tioga using the same command you did.
I got the following terminal output and also found the following new file in profiles_out.

/Users/bpaxton/mesa/star/work/star_profile: tioga by_mass -m 0
loading /Users/bpaxton/mesa/star/work/star_profile/by_mass.rb
log_mass_frac_ymin -6
xs.length 1040
xs[0] 2.98962080547118
xs[-1] 1.17545985800201e-07
@xmin
@xmax
@grid_min 0
@grid_max -1
xs[@grid_min] 2.98962080547118
xs[@grid_max] 1.17545985800201e-07
show_by @xaxis_by mass name abundances
no frills false
eval_str  =   abundances(xs, xlabel)
 Abundances_figure.pdf
  0  /Users/bpaxton/mesa/star/work/star_profile/profiles_out/Abundances.pdf


Do you get similar terminal output to this?

Try putting these files in your work/LOGS.  Then you'll have the same data for plotting as I do.

You should then get the same pdf output.  Do you get anything?

-Bill




On Jan 24, 2012, at 6:14 PM, Giannotti, Maurizio wrote:


I have been using MESA for a while, and lately I have tried to install Tioga. Everything seems to go well. I can run the examples in the tioga folder, see the pdf of the Tioga icon, and also the blue and the red figures. However, when I try to make a plot from the Mesa/work folder, Tioga does not produce any output. For example, if I go in the star_profile folder and run

tioga by_mass -m 0

it does make the folder profiles_out, and I get a message that indicates the production of the file Abundances.pdf. However the file is not there. No error message. I have had this problem for several weeks, and no matter what I do, I cannot produce the pdf files.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20120125/39c19ec4/attachment.html>


More information about the Mesa-users mailing list