[mesa-users] Installing MESA on a supercomputer

Kevin Moore kmoore at physics.ucsb.edu
Wed Jan 4 14:23:14 EST 2012

Hi all,

I'm trying to install MESA on the Triton computing cluster at UCSD and am getting some weird errors. I know next to nothing about this so am just following the instructions on Rich's website for using the MESA SDK (which has worked fine for my macbook many times). uname -m returns "x86_64" so I'm using the 64-bit linux version of the SDK. All the setup steps seem to work fine (no errors anyway), but I run into problems during the ./install step.

The first error I encounter is:
gfortran: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by gfortran)
make: *** [const_def.o] Error 1

Perhaps tellingly, there is not a file named libc.so.6 in my mesa/utils/mesasdk/lib64.

In addition, now whenever I try and use the man command I get the error:
/usr/bin/gtbl: error while loading shared libraries: /home/kmoore-ucsb/mesa_3794/utils/mesasdk/lib64/libstdc++.so.6: ELF file OS ABI invalid

Any ideas what's going on from someone who may have done this before?


More information about the Mesa-users mailing list