[mesa-users] eos error

Jeff Andrews andrews at astro.columbia.edu
Mon Oct 17 16:45:54 EDT 2011

Hello everyone,

I'm trying to install MESA version 3661, using gfortran version 4.6.1.
(probably not a compiler issue?)

I ran ./install, and things appeared to go smoothly, until I ran into a
segmentation fault when the install script ran the test program in
/mesa/eos.  The following is the last part of the output:

 read  ../../data/eosDT_data/helm_table.dat
 write  ../../data/eosDT_data/cache/helm_table.bin
../utils/build_and_test: line 33: 11280 Segmentation fault


./build_and_test FAILED

After some work, I found the offending line in the file eosDT_load_tables.f
in mesa/eos/private:
         tbl(1,eosDT_ilnPgas,:,:) = tbl2(jlogPgas,:,:)*ln10

Maybe it isn't loading the eos tables correctly?  That seems strange because
the install script said the eos data was successfully installed.

Any help would be greatly appreciated!!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.mesastar.org/pipermail/mesa-users/attachments/20111017/e32d116f/attachment.html>

More information about the Mesa-users mailing list