[mesa-users] Re-compiling EOS tables

Dr. Enrico Olivier olivier at saao.ac.za
Fri Jan 21 05:04:18 EST 2011

Hi I tried to recompile the EOS tables but I got the following message when executing "./replace_DTdata" following the steps in the README file.

create eosDT_data
bzip2 -d eosDT_data.tar.bz2
mv: cannot stat `data/eosDT_data/*.data': No such file or directory

I then tried to get things working with a sledgehammer approach by recompiling all of MESA again with a  "./clean" and then a "./install". Things compiled fine untill the following error appeared:

 read  ../../data/eosDT_data/helm_table.dat
ERROR: failed to open ../../data/eosDT_data/helm_table.dat : ios      2
ERROR: read_helm_table failed
 failed in eos_init
 ERROR: read_helm_table failed

Can someone point me a way around this? I am trying to use the EOS module without radiation included, by trying to set crad=0 and then recompiling the tables. I am doing this "absurd" thing since I am wanting to use the EOS module in an application where I treat the radiation and gas separately and don't assume the gas and radiation is necessarily in equilibrium. 

Can anyone help? 

Thank you,

More information about the Mesa-users mailing list