mesa-users] "bad composition in setup for kap builder"

Bill Paxton paxton at
Wed May 20 15:34:47 EDT 2009

Hi Petar,

That's a new one!  But hopefully we'll find a fix.

During the first install, or when the opacities data has been updated,
the install process builds new opacity tables.   When the top-level
mesa/install script finds that the mesa/data/kap_data directory is
missing or the data/kap_data/tag data/kap_data/tag_cpy file
isn't up to date, it runs the 'build_data_and_export' script in kap.

That script in turn cd's to kap/preprocessor where it does 'mk',
and then 'rn_all'.  The rn_all script builds the data files, and it
seems to be having trouble with  You can find
the line of code that's complaining in kap/preprocessor/src/ 

          if (Zbase+X+XC+XO > 1) then
             write(*,*) 'bad composition in setup for kap builder'
             stop 1
          end if

Let's add a few lines to print out the offending sum that's > 1.
Here's what I added at the start of the setup routine:

          include 'formats.dek'

          write(*,1) 'Zbase+X+XC+XO', Zbase+X+XC+XO
          write(*,1) 'Zbase', Zbase
          write(*,1) 'X', X
          write(*,1) 'XC', XC
          write(*,1) 'XO', XO

And when I ran it, I got this:

                            Zbase+X+XC+XO    1.0000000000000001E-01
                                    Zbase    1.0000000000000001E-01
                                        X    0.0000000000000000E+00
                                       XC    0.0000000000000000E+00
                                       XO    0.0000000000000000E+00

So it looks like the problem may be that trailing '1' in Zbase.
On my machine, it seems to be ignored (perhaps the compiler
is doing me a favor?).   It seems that the test comparing the sum to 1
is wrong.   Why don't you try changing it to the following:

          if (Zbase+X+XC+XO-1 > 1d-9) then
             write(*,*) 'bad composition in setup for kap builder'
             stop 1
          end if

Please let me know if that helps!

BTW: what system & compiler are you using?


On May 20, 2009, at 12:14 PM, Petar Todorov wrote:

> Dear MESA list,
> I'm a newbie with MESA, so my problem will probably be trivial for  
> most of
> you, but unfortunately I can't overcome it. So, my problem is that the
> compilation stops when it comes to build the opacities tables (just  
> after
> the EOS was built):
>> creating data/kap_data/
>> bad composition in setup for kap builder
>> STOP 1
> What does it mean? I didn't find with grep which script shows this  
> error
> message (I also browsed several scripts in the mesa and mesa/kap
> directories) and google wasn't my friend either when tried to see if  
> this
> is a standard error message.
> Regards,
> Petar
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables
> unlimited royalty-free distribution of the report engine
> for externally facing server and web deployment.
> _______________________________________________
> mesa-users mailing list
> mesa-users at

More information about the Mesa-users mailing list