mesa-users] Compiling MESA EOS and OPACITY modules

Mon Dec 14 10:49:07 EST 2009

Hi Ricky,

I suggest you download the code using svn instead of tar file. As
Bill suggested, try the new gfortran, for my case, I upgraded the
whole system, gcc and gfortran 4.3.0 (previously I used ubuntu 8.04,
then the same problem happen and I upgraded using ubuntu 9.04 where
it come with gfortran 4.3.0 I think) and it works smoothly without
any error.

Hope it helps.



Quoting Ricky Olivier <olivier at> on Mon, 14 Dec 2009
17:42:09 +0200:

> Hi Bill,
> Tried that already. Even deleted the mesa root directory and
> it from the original tarball. Still no luck ...
> Ricky
> Bill Paxton wrote:
>> Hi,
>> Let's try again with gfortran.
>> To ensure that everything has been
>> recompiled with the new compiler,
>> remove the old stuff and then
>> redo the entire install by doing this:
>> cd mesa
>> ./clean
>> ./install
>> Once you have completed a normal install,
>> the eos and kap tables will have been created
>> automatically, so let's focus on the install
>> for now.
>> Bill
>> On Dec 14, 2009, at 6:18 AM, Ricky Olivier wrote:
>>> Dear Bill,
>>> Thanks for the info. I upgraded to gfortran 4.5.0 and still it
>>> It seems to hang at the following compilation line:
>>> gfortran -fopenmp -o ../tester test_superlu.o test_sparskit.o
>>> test_mtx.o -L../../make -lmtx -L../../../lib  -lmesalapack
>>> -lutils -lalert
>>> On another point, I looked through all the directories, and I
>>> don't find the eos and kap tables anywhere. Thanks to both you
>>> Aaron's  responses so far.
>>> Ricky
>>> Bill Paxton wrote:
>>>> Hi Ricky,
>>>> The "infinite hang" symptom has happened in the past with
>>>> older versions of gfortran.  So, my first suggestion is to
>>>> try again with the most recent gfortran version --
>>>> for example, I'm using 4.5.0 without problems.
>>>> you can get gfortran binaries to download at
>>>> -Bill Paxton
> Return on Information:
> Google Enterprise Search pays you back
> Get the facts.
> _______________________________________________
> mesa-users mailing list
> mesa-users at

Norhasliza Yusof
Dept of Physics
University of Malaya
50603 Kuala Lumpur
UNIVERSITY OF MALAYA  -  " The Leader in Research & Innovation "

'This email and any files transmitted with it are confidential and  
intended solely for the use of the individual or entity to whom they  
are addressed.  If you have received this email in error, please  
notify the system manager.  Please note that any views or opinions  
presented in this email are solely those of the author and do not  
necessarily represent those of the University.  Finally, the recipient  
should check this email and any attachments for the presence of  
viruses.  The University accepts no liability for any damage caused by  
any virus transmitted by this email.'

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Mesa-users mailing list