mesa-users] Compiling MESA EOS and OPACITY modules

Ricky Olivier olivier at
Sun Dec 13 08:27:27 EST 2009


Thanks to those who responded to my earlier message. Aaron, I tried what 
you suggested, but now the compilation proceeds to a point where it just 
hangs. I waited over 4 hours and still not finished. Seems to get stuck 

Anyways I am just interested at the moment in using the EOS and OPACITY 
modules in my linear and non-linear pulsation code.I tried to compile 
these separately and just end up with the following:

ricky at rickylapvm:~/mesa_1.1.1/eos$ ./install
gfortran  -fopenmp -I../public -I../../include -Wunused-value 
-Wuninitialized -Werror -W -fimplicit-none   -O2 -c -ffixed-form 
-ffixed-line-length-132 ../private/eos_eval.f

Fatal Error: Can't open module file 'num_lib.mod' for reading at (1): No 
such file or directory
make: *** [eos_eval.o] Error 1


Any ideas? Where is num_lib.mod located? By the way, I don't think I got 
the actual data tables either. Where can I find these? I just downloaded 
the tarball of the site.

Thank you.


More information about the Mesa-users mailing list